Page 1 of 1

Board failures

Posted: Tue Jun 16, 2015 10:13 pm
by basicchip
It is pretty hard to diagnose a failure when I don't really have any information on the end user application (too often the case). so here are some general comments. The NXP ARM CPUs are pretty tough parts, but not indestructible. Most of the parts we use are very popular, with many millions in the field.

Power supply failures, the parts we use (mostly from TI) have thermal and overcurrent shutdown. However prolonged shorts to ground and over-voltage can damage these parts. Especially if you apply voltage to them without the input (non-regulated) voltage applied.

IO pin failures, if you drive too much current through them they can be damaged. This can be especially true if you apply low impedance (possible high currents) before the power supply to the chip is connected.

Some clues might be if you damage the same pin on more than one device, maybe there is something wrong with your application circuit.

While the parts are 5V tolerant (while the supply is connected), they do not do well with voltages greater than 5V.

The analog inputs are NOT 5 volt tolerant and behave badly with voltage above 3.3V. They won't be damaged, but the internal analog mux may go haywire when any of its inputs is above 3.3V.

Static, yes it can be a problem, and any production facility I have worked at has very rigid anti-static procedures, wrist straps, conductive smocks... Now I have to admit, I don't take all these precautions on my test bench, but I realize that in the long run that could cause some issues. Many studies have shown that while static may not destroy an IO, it can weaken it, such that repetitive static can lead to a failure later.

So when you have an issue, think about what you were last doing with the part.

- Did you connect some new interface circuit?

- Do you have voltages greater than 5V in the system?

- If you have those higher voltages, how to you protect the rest of the circuit?

- Pay attention to power supply sequencing, the ARM should come up before your external circuit applies voltage to the ARM

- When there are higher voltage, it is easy to accidentally connect them to the lower voltage area (we have all done it, a slipped probe ...)